reCaptcha error

Hi All,

I have deactivated the Advanced Google reCaptcha plugin from Dev env. When I try to login from Dev / Site Admin, I could do so without any problem and no reCaptcha errors are shown. Then I deploy from Dev to Test env. When I try to login from Test / Site Admin, the User/Pass fields are shown correctly but under them I am getting this error “ERROR for site owner: Invalid domain for site key”. I thought that when I deploy from Dev to Test environment everything will be copied and no differences will be spotted. Still I cannot login in the Test / Site Admin because of the reCaptcha error. Does someone else came across this kind of issue?

1 Like

Hey @slavyan.stoyanov! :wave:

Thanks for joining the Community Hub! I am sorry to hear you are bumping into issues here.
While this is a peer-to-peer support community, I am going to tag on a few people here to see if they can help get you back on track :slight_smile:


1 Like

Hey @slavyan.stoyanov! I realized the people I tagged in here didn’t get around to your question. Do you still need help? Happy to ask some other people internally here. So sorry about that!

1 Like

I set my v3 site key and secret key from the google recaptcha console. Then I install and activate the Advanced Google reCaptcha plugin and from the setting I put the generated site key and the secret key. I am given the options where I want the reCaptcha to appear. I put a checkmark on the default login page. And when I try to login again to my wordpress login (Dev env.) I fill in the username and the password and I given the following error: " ERROR: Google reCAPTCHA verification failed."

Hey @slavyan.stoyanov! I chatted with someone here on our support team and they informed me that this is not Pantheon platform related, so they are unable to help much here. She did however, share this WordPress support thread:

Hopefully this helps! If not, I might also suggest asking around in our Community Slack. We have lots of devs there who may be able to help!